16/10/10

Solución: XAMPP: Error 1! Couldn't start Apache! [SOLUCIONADO]

XAMPP es una forma fácil de instalar la distribución Apache que contiene MySQL, PHP y Perl.
Lo instalé varias veces sin problemas. Pero ayer, cuando lo instalé e intenté correr, me tiraba este error:

$ sudo /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.3a...
XAMPP: Starting Apache...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.
Luego de buscar y probar soluciones, esta solución es la que me funcionó.

Para solucionarlo hay que parar apache2:
$ sudo /etc/init.d/apache2 stop
Y listo. Reiniciamos XAMPP (si ya lo habíamos intentado iniciar):
$ sudo /opt/lampp/lampp restart
Ya tenemos XAMPP Funcionando!

Finalmente, si queremos podemos desinstalar apache2 para que no vuelva a molestar.

:)

12 comentarios:

cesar dijo...

muy bueno si me funciono

saludos...

Anónimo dijo...

muchas gracias! me sirvió a mi también...

webmaster dijo...

no me sirvio tu wea

webmaster dijo...

wenas ya encontre la solucion se que a muchos les sirvio lo de arriba pero a lo sque dejamos la caga instalando y desintalando weas con distintas respuestas nos nos funciono lo que hice despues de que no me funciono ninguga ayuda de un foroi fue esto:
elimine todo :P y lo instale denuevo

sudo aptitude purge xampp
sudo aptitude purge lampp
sudo aptitude purge php
sudo aptitude purge mysql

y despues instale por sepadado

sudo aptitude install php
sudo aptitude install phpmyadmin
sudo aptitude install mysql

y listoco todo corriendo normal

oo la cago como 4 horas webiando ya nos vemos un abrazo un saludo de chile chauu

Anónimo dijo...

Sencillo y efectivo. Muchas gracias

Juan Diego dijo...

Gracias

Funcionó bien.

(Estoy intentando correr mediawiki en xampp)

jbriz dijo...

Gracias, reinstale 3 veces el xampp y nada hasta q encontre esta solucuon y funciono genial.
no se porque si lo hacia con el oanle de control de xampp y no funcionaba

Anónimo dijo...

Muchísimas gracias ¡Ha funcionado! :-)

Anónimo dijo...

Hola,

No funciona con esto. El servicio apache2 no existe. O se usa xamp (lampp en linux) o se usa apache + php + mysql.

Xampp (lampp) lo trae todo portable, sin necesidad de tener instalado ninguno de los mencionados anteriormente.

Es ridículo, absurdo, etc tener que parar el proceso apache2 del sistema. Ese proceso ni debería existir si estás con xampp.

Anónimo dijo...

MUCHAS GRACIAS.

Adriana dijo...

También me sirvió. Qué súper encontrar comunidad que comparte esto. Muchas gracias. Espero en algún momento poder ayudar también.

Anónimo dijo...

Excelente brother!!! Me funcionó gracias por tu aporte

Related Posts Plugin for WordPress, Blogger...